Magazine

Outriders armour has been bugging out but there’s a simple solution

Outriders devs would be "happy" to make big expansions

If you’ve been noticing you’re getting absolutely destroyed in Outriders expeditions recently, you’re not the only one. Since the latest 1.07 update dropped last week, the game’s been having a bit of an issue with armour and survivability. Thankfully one nifty redditor has figured out a quick fix. It’s a fix that’s done right by the PC gaming community for years now… just simply turn your armour off and on again.

Well, unequip it and re-equip it. Redditor Thorkle13 shared the fix after saying they’d become frustrated with how squishy their character appeared to be, with damage mitigation being “nearly nonexistent even with defense mods equipped.” Apparently unequipping and re-equipping the armour right before the expedition improved the damage mitigation, writing “it doesn’t turn me into a tank God or anything, but it lets me have a chance again.”

The fix seems to have been corroborated by a few other redditors in the replies, though the exact cause hasn’t quite been pinned down. One reply suggested that armour is currently completely broken, with the fix just causing defense mods to work again. Another reply pointed out that certain mods were breaking after cutscenes, though that could be a separate issue entirely.

It isn’t the first time the old “have you tried turning it off and on again” trick has worked for Outriders, with it being the solution to a bug that was causing the HUD to disappear. Of course, the fix may not work for everybody, but it’s definitely worth giving a go if you’ve been struggling more than usual. 


Continue Reading: Source link

Similar Posts